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Source-Nexus Control Panel: Failed to get box ID

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Cannot add a device

Failed to get box ID 

Source-Nexus Control Panel | All Versions | macOS

Description

After uninstalling and re-installing Source-Nexus, users face this error when adding new devices or opening the Source-Nexus Control Panel application: 

Cause

  • Conflicts between the Source-Nexus I/O versions on the user's computer.
  • Source-Nexus I/O driver was not installed correctly.
  • A file permissions issue.

Actions

In order to fix the error message (for versions of Source-Nexus I/O older than 1.3):

  1. Uninstall ALL Source-Nexus software (Control Panel and the I/O plugin) from your computer.
  2. Restart the computer.
  3. Install Source-Nexus Control Panel 1.0 first.
  4. Install Source-Nexus I/O Pro 1.2.
  5. If the error remains, download and install Source-Nexus I/O 1.3, then uninstall it, then install Source-Nexus Control Panel 1.0 and Source-Nexus I/O Pro 1.2.

To fix the error in Source-Nexus I/O 1.3 and newer, first try restarting the computer and launching the Source-Nexus Control Panel application again. If that does not work, proceed to the following:

  1. Uninstall Source-Nexus I/O 1.3.
  2. Install Source-Nexus I/O 1.3.

You can also manually delete the driver from /Library/Audio/Plug-Ins/HAL/Source-Nexus.driver if there' an issue removing the driver during uninstall.

If that does not resolve your issue, try restarting Core Audio with the following command: sudo launchctl kickstart -kp system/com.apple.audio.coreaudiod. Also, please note that Core Audio is restarted with the computer on reboot.

If this does not resolve your error, delete the following file: /Library/Preferences/Audio/com.apple.audio.SystemSettings.plist (please note that this will remove your audio device configurations). Then, restart the computer, and try accessing Source-Nexus Control Panel again.

If the error persists, contact our support team.

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